·
The issue should be resolved now.
Resolved
Monitoring
We're monitoring fixes as the system recovers.
Investigating
We're working on fixing the degraded performance issues across the product.